블로그 이미지
훅크선장

카테고리

분류 전체보기 (306)
사진이야기 (23)
펭귄컴퓨팅 (92)
컴퓨터보안 (66)
절름발이 프로그래머 (59)
하드웨어개조 (16)
멀알려줄까 (34)
잡다한것들 (15)
Total638,094
Today10
Yesterday82

달력

« » 2017.08
    1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28 29 30 31    

공지사항

태그목록

라즈베리 파이에서 유선랜 라우터 만들기


0. 라즈베리 파이에 라즈베리안 설치하고, 부팅한 다음, 기본 설정 해줍니다.

$ sudo raspi-config

명령을 실행하고, 다음의 작업을 실시


Expand the root filesystem and reboot

Boot to commandline, not to GUI

Configure the right keyboard map and timezone

Configure the Memory Split to give 16Mb (the minimum) to the GPU

Consider overclocking to the Medium (900MHz) setting on Pi 1, or High (1000MHz) setting on Pi 2



$ sudo su -

명령으로 root 권한에서 작업하는 것이 편하다.


1. 당연히 USB 유선랜 어댑터가 인식되어야 하겠지요?!

# ifconfig -a

에서 eth1 이 있어야죠


2. /etc/network/interfaces 파일에서 eth1에 정적 아이피 주소 설정하기

※ 이미 eth0는 게이트웨이 인터페이스로 dhcp 설정이거나, 아니면 static IP 주소를 설정했다고 가정 


allow-hotplug eth1

iface eth1 inet static

  address 192.168.144.1

  network 192.168.144.0

  

hotplug가 필요한지 의문이긴 한데,  eth1에 정적인 아이피 주소와 네트워크 대역만 설정


3. eth1 이 eth0 게이트웨이를 이용해서 패킷이 나갈 수 있도록, 포워딩 설정이 필요


패킷 포워딩은 커널 파라미터 설정 명령 하나와 Net Filter인 iptables 명령어 3개로 구성

1) 포워딩 설정

# echo 1 > /proc/sys/net/ipv4/ip_forward

하고,

/etc/sysctl.conf 에서 포워딩 라인을 언코멘트(맨앞의 # 글자 삭제)한다.


# Uncomment the next line to enable packet forwarding for IPv4

net.ipv4.ip_forward=1


파일 수정을 완료한 다음에, # sysctl –system 명령으로 시스템에 적용할 수도 있다.


2) Net Filter 설정 


# iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

# iptables -A FORWARD -i eth1 -o eth0 -m state --state RELATED,ESTABLISHED -j ACCEPT

# iptables -A FORWARD -i eth1 -o eth0 -j ACCEPT


세 개의 명령을 재부팅에서도 동일하게 가지고 가려면, 두가지 방법이 있다.

먼저, 쉡 스크립트로 매번 재부팅때마다 실행 


현재 Net Filter 설정을 파일로 저장 

# iptables-save > /etc/iptables.ipv4.nat 


그리고,  /etc/network/interfaces 파일에 다음의 구문을 추가한다.


up iptables-restore < /etc/iptables.ipv4.nat


Net Filter 설정 구문을 rc.local 파일에 추가해서 실행하는 방법도 있다.

/etc/rc.local 파일 맨 마지막에 


/sbin/iptables-restore < /etc/iptables.ipv4.nat

를 추가.


스크립트 방식이 미덥지 않으시면, 대안으로,

두번째, 별도 패키지 설치


# apt-get install iptables-persistent

The installer will ask if you want to save current rules, select Yes

설치할 때, 현재 룰을 저장할꺼냐고 물어보면 “Yes”를 선택,

만약 나중에 별도로 룰을 저장하고 싶으면,  # netfilter-persistent save  하면 된다능.


매번 부팅할때, 설정이 다시 동작하도록 하려면,

# systemctl enable netfilter-persistent

로 마무리.


4. DHCP 서버 설치와 설정 


apt-get install isc-dhcp-server


/etc/default/isc-dhcp-server  파일에서 dhcp가 동작할 인터페이스 설정


INTERFACES="eth1"

으로 설정


/etc/dhcp/dhcpd.conf  에서 서브도메인 설정


#option domain-name "example.org";

#option domain-name-servers ns1.example.org, ns2.example.org;


위 두 라인을 커맨트 처리 (맨 앞에 # 글자 삽입)


dhcp로 할당될 IP 주소들 범위를 정의,

다음과 같이 추가


subnet 192.168.144.0 netmask 255.255.255.0 { 

  range 192.168.144.100 192.168.144.200;

  option domain-name-servers 192.168.137.1;

  option domain-name "internal.example.org";

  option routers 192.168.144.1;

  option broadcast-address 192.168.144.255;

  default-lease-time 600;

  max-lease-time 7200;

}


subnet 은 eth1에 할당한 네트워크와 동일하게 하고, range는 dhcp로 할당할 아이피 대역을 정의

도메인 네임 서버는 eth0에 연결된 실제 인터넷 DNS 아이피를 써주면 되고, 라우터 아이피는 라즈베리파이의 eth1 인터페이스 아이피 주소를 쓰면 됩니다.


만약에 도메인 네임서버를 쓰는 곳에서, eth0 게이트웨이가 연결된 곳이 DHCP로 IP를 받는다면, dnsmasq 패키지를 설치해서, 현재의 리눅스 머신, 라즈베리파이가 DNS 쿼리를 상위로 던져서 처리할 수 있도록 할 수 있습니다.

option domain-name-servers 192.168.144.1

도메인 서버를 현재 머신의 아이피 eth1 의 IP로 설정하시고,

# apt-get install dnsmasq

하면 됩니다.


서버가 잘 실행되면,

# update-rc.d isc-dhcp-server enable 

명령으로 항상 시스템 부팅때, 서비스가 실행되도록 설정한다.


5. eth1 쪽에 노트북 같은 것을 붙여서, dhcp 로 아이피 잘 받아오는지?  외부로 ping 이 잘 가는지?, 그리고 인터넷이 되는 지를 검사한다.

아이피가 안 받아지면, dhcpd 설정 문제이거나, eth1 쪽 인터페이스 네트워크 설정에 문제가 있는 것이고,

인터넷만 안된다면, dns 설정문제일 가능성이 높다.

안되는 경우에는 네트워크 설정을 하나씩 짚어보면서, 체크할 것.


dhcpd 의 에러상태를 보고 싶다면, 

# systemctl status isc-dhcp-server 로 볼 수 있다.


간혹 게이트웨이들이 ping을 받지 않을 수 있기 때문에, 나는 ping 던지는 대상은 항상 www.centos.org 같은 도메인으로 하거나, 기존에 ping을 잘 받는 네트워크 장비나 리눅스 머신에게만 쏜다~!



------ 현재 작업중인 내용 -------


1. dnsmasq 를 사용한다면, 굳이 isc-dhcp-server을 쓰지 않아도 된다.  dnsmasq 는 dhcp 서버 기능을 가지고 있기 때문이다.

2. hostapd 를 설치하면, wifi 어댑터를  무선 AP(Access Point)로 사용할 수 있다.  eth1 인터페이스가 wlan0 인터페이스로 바뀌는 것 말고, 위 내용에서 달라질 것은 크게 없다. hostapd 에서 무선접속 설정은 반드시 해야 한다.

3. 흔히 집에서 쓰는, 유무선공유기 (Home Router)와 같이 유선과 무선이 동일한 IP 대역을 가지고 자유롭고 연결되는 네트워크 환경을 만들고 싶다면, bridge 기술을 사용해서(bridge-utils 패키지를 설치), 두 개 이상의 네트워크 인터페이스를 통합하면 좋다.  

※ Bridge 기술을 안쓰면, Net Filter 정의가 많이 복잡해질 것이다. iptables 명령어를 엄청 많이 고민해서 넣어야 할 지도 모른다. 그래서, Bridge 기술이 좋은게 좋은거다~!



저작자 표시
신고
Posted by 훅크선장

최근 유무선공유기 펌웨어 업데이트를 다시 해보니,

펌웨어 업데이트에서 가장 좋은 방법은 TFTP를 이용하는 방법이다.

왜냐하면, 네트워크상에서 바로 펌웨어를 공유기에 주입할 수 있기 때문이다. 기존에 설치된 펌웨어의 웹 인터페이스에서 업그레이드를 하려고 하면, 반드시 펌웨어의 버전 검사나 기타 검사에 의해서 펌웨어를 안 받아들이는 경우가 많기 때문에.(모든 공유기 회사의 번들 펌웨어도 그렇고, DD-WRT도 그렇고,  OpenWRT라고 다르지 않다.)



그래서, 맥(Mac OS X)에서 TFTP 서버를 구동시키고, 펌웨어를 TFTP로 전달하면 된다.


참고한 사이트는 http://www.barryodonovan.com/2014/11/08/os-x-built-in-tftp-server 이다. 


맥에서 터미널을 하나 열고,


# sudo launchctl load -F /System/Library/LaunchDaemons/tftp.plist

# sudo launchctl start com.apple.tftpd


이러면, TFTP 서버가 가동된다.


펌웨어는 /private/tftpboot/ 에 넣어주면 된다. 여기가 TFTP 서버의 root directory이다.


# cd /private/tftpboot

# sudo cp ~/Download/new_firmware.bin ./


이렇게 해서, 네트워크를 TFTP 용으로 설정하고, 공유기의 펌웨어를 업데이트를 진행하면 된다.

각각 공유기 회사마다 TFTP용 네트워크 설정이 따로 있으니, 이건 각 회사 매뉴얼을 참고하면 된다.

openwrt.org에 가면, 왠만한 공유기의 정보는 다 있으니, 거기도 참고할 만하다.


이미 가동된 TFTP서버를 정지하려면,


# sudo launchctl unload -F /System/Library/LaunchDaemons/tftp.plist


이 명령어 하나면 된다.


저작자 표시
신고
Posted by 훅크선장

이전에 썼던 글에서, OpenWRT에서 OpenVPN 사용을 위한 방화벽 iptables 허용 규칙


방화벽 규칙을 iptables 가 아닌, netfilter로 사용하는 방법입니다. 두 방법에 차이는 없지만, 외국의 사용자들은 netfilter를 더 권장하는 것 같습니다.

/etc/firewall.user는 일종의 custom 룰로 사용하다보니, 좀 더 근본적인 네트워크 필터링?은 netfilter를 더 선호하는 것 같습니다.


/etc/firewall.user  파일에서 사용한 다음의 세 줄이 대상입니다.


###OPENVPN PASS-THROUGH ENABLE RULES###

iptables -I INPUT -p udp --dport 1194 -j ACCEPT

iptables -I FORWARD -i tun+ -j ACCEPT

iptables -I FORWARD -o tun+ -j ACCEPT


----------------------------------------------------------------------------------------------

먼저 위의 세 줄을 모두 주석처리합니다.

# vi /etc/firewall.user

...

###OPENVPN PASS-THROUGH ENABLE RULES###

#iptables -I INPUT -i eth+ -p udp --dport 1194 -j ACCEPT

#iptables -I FORWARD -i tun+ -j ACCEPT

#iptables -I FORWARD -o tun+ -j ACCEPT

...


/etc/config/network 파일에 다음을 추가합니다.

...

...

config interface 'vpn0'

        option proto 'none'

        option ifname 'tun0'


네트워크 인터페이스를 하나 생성하는 것입니다.


/etc/config/firewall 파일에 다음을 추가합니다.(중간쯤에 추가하면 좋습니다.)


config zone

option input ACCEPT

option output ACCEPT

option name openvpn_zone

option network 'vpn0'

option forward REJECT


config forwarding

option dest lan

option src openvpn_zone


config forwarding

option dest wan

option src openvpn_zone


config forwarding

option dest openvpn_zone

option src lan


config rule

option target ACCEPT

option src wan

option proto udp

option dest_port 1194

option family ipv4

option name 'openvpn2openwrt'


순서대로 설명하면,

먼저 vpn 영역의 zone을 생성해줍니다.

두번째로 포워딩을 정의합니다. 포워딩 룰은 모두 3개를 정의합니다.

vpn 영역에서 lan 영역으로,  vpn 영역에서 wan 영역으로, 그리고, lan 영역에서 vpn 영역으로,

총 3개를 정의하면, vpn 상에서 lan 과 wan에 모두 연결이 됩니다.

마지막으로, openvpn 서비스가 사용하는 1194 포트에 대해서 udp 접속이 허가되도록 해줍니다.


이렇게 하고나서, 반드시 OpenWRT 장비를 리부팅해야 됩니다.  zone 설정은 시스템이 재시작되어야만 적용되기 때문이라고 합니다.

# /etc/init.d/network restart

# /etc/init.d/firewall restart

만으로는 해결되지 않습니다.

반드시, OpenWRT 장비를 리부팅해야만 합니다.



저작자 표시
신고
Posted by 훅크선장

OpenWRT에서 WAN Interface 명칭과  LAN 인터페이스 명칭을 쉡 스크립트로 사용하여 알 수 있습니다.


Interface 명칭은 보통 eth0, eth1, 등등 인데, OpenWRT에서는 br-lan 이라는 인터페이스 명이 주로 내부 LAN 이름으로 사용됩니다.

UCI 명령어를 쓰면 인터페이스 명칭을 쉽게 알아낼 수 있습니다.


WAN 인터페이스 명칭 알아내기

uci -P/var/state get network.wan.ifname

결과값은

eth0

으로 출력됩니다만, 다른 장비들에서는 eth1 으로 출력되기도 합니다. 주의하셔서 보셔야 합니다.

LAN 인터페이스 명칭 알아내기

uci -P/var/state get network.lan.ifname

결과값은

br-lan

으로 대부분 출력됩니다.



위의 스크립트는 다양한 곳에서 사용할 수 있습니다.

대표적으로 방화벽 설정파일인 /etc/firewall.user 파일에 적용할 수 있습니다.


WANIF=$(uci -P/var/state get network.wan.ifname)

iptables -A INPUT -i $WANIF -p tcp --dport 21 -j ACCEPT

와 같은 식으로, WAN 인터페이스를 지정하는 스크립트를 장비의 출력값에 구애받지 않고 쓸 수 있는 장점이 있습니다.

저작자 표시
신고
Posted by 훅크선장

OpenWrt Chaos Calmer 15.05 에서 테스트된 내용으로,

OpenVPN 클라이언트가 OpenWRT의 OpenVPN 서비스로 접속하여, 인터넷을 하기 위한 iptables 규칙을 설명합니다. (클라이언트의 패킷들이 OpenWRT 공유기를 통하여, 인터넷으로 Forwarding 되기 위한 조건)


/etc/firewall.user  파일에 다음과 같이 딱 세 줄만 추가하면 됩니다.


###OPENVPN PASS-THROUGH ENABLE RULES###

iptables -I INPUT -p udp --dport 1194 -j ACCEPT

iptables -I FORWARD -i tun+ -j ACCEPT

iptables -I FORWARD -o tun+ -j ACCEPT


앞의 첫째 줄,

iptables -I INPUT -p udp --dport 1194 -j ACCEPT

이것들은 1194 포트(OpenVPN의 디폴트 Listen 포트번호)로 들어오는 udp 패킷을 받아들이는 것입니다.

이 라인이 없으면, OpenVPN 서비스 접속 자체가 불가능합니다.

만약 특정 네트워크 인터페이스에서만, OpenVPN 서비스를 사용한다면, 다음과 같이 인터페이스를 지정할 수 있습니다.

iptables -I INPUT -i eth0 -p udp --dport 1194 -j ACCEPT


eth0는 예로 든 것입니다. 일반적으로는 ifconfig  명령을 실행한 다음, 인터넷과 연결된 WAN 인터페이스를 찾아야 합니다. 경험상으로 eth0 또는 eth1이 주로 WAN 인터페이스입니다만, 어느쪽이 될지는 OpenWRT가 설치된 장비에 따라 틀립니다. 반드시 확인하시기 바랍니다.


만약 OpenVPN을 tcp 모드로 사용한다면,  다음과 같이 수정해서 사용하여야 한다. (OpenVPN은 udp 모드로 사용해야 좋습니다. udp 모드가 tcp 모드에 비해 속도가 빠르다고 합니다.)

iptables -I INPUT -p tcp --dport 1194 -j ACCEPT

--dport 뒤에 쓰여진 1194 라는 번호도 역시 디폴트 OpenVPN 포트번호이므로, 혹시 다른 포트를 사용하기로 설정했다면, 여기도 수정해서 사용해야 한다.


그 뒤의 두 줄,

iptables -I FORWARD -i tun+ -j ACCEPT

iptables -I FORWARD -o tun+ -j ACCEPT

이것들은 OpenVPN으로 연결된(tun 디바이스명을 가진) 네트워크 어댑터들의 패킷들이 다른 네트워크 디바이스 쪽으로 서로 왕래할 수 있도록 합니다.


-i tun+ 가 있는 줄은 tun 디바이스 명을 가진 네트워크 어댑터에서 출발한 패킷들이 다른 네트워크 어댑터, 즉 OpenWRT 공유기의 LAN 영역이나 WAN 영역으로 전달될 수 있도록 하는 것입니다.

-o tun+ 가 있는 줄은 OpenWRT 공유기의 LAN 영역이나 WAN 영역에서 출발한 패킷들이(아마도 대부분은 윗 줄의 패킷들에 대한 응답들이 많은) tun 디바이스명을 가진 네트워크 어댑터쪽으로 다시 들어올 수 있도록 하는 것입니다.


------------------------------------------

대부분의 OpenWRT의  OpenVPN 서비스가 사용할 빈도가 적겠지만,

만약 OpenVPN 서비스에 접속한 외부의 클라이언트들이 OpenWRT 내부의 LAN 영역에만 접근가능하도록 하고, 인터넷을 사용하지 못하게 하려면, (ex. 회사내의 서버만을 연결하는 경우)


위에서 설명한 FORWARD 규칙 두 줄을 다음과 같이 수정하면 됩니다.

iptables -I FORWARD -i tun+ -d 192.168.1.0/24 -j ACCEPT

iptables -I FORWARD -o tun+ -s 192.168.1.0/24 -j ACCEPT


여기서, 192.168.1.0 네트워크는 OpenWRT의 내부 LAN  IP 대역을 지칭하는 것입니다. 여러분의 환경에 맞게 확인하시고 입력하시면 됩니다.


 -d 192.168.1.0/24 를 -o br-lan 으로,  -s 192.168.1.0/24 를 -i br-lan  으로 바꾸어 쓸 수 없습니다. (br-lan은 OpenWRT의 내부 LAN 영역을 지칭하는 디바이스명입니다.) 이유는 확실하지 않지만, 일단 br-lan 영역에 패킷이 들어오면, 공유기의 기본 기능으로 인하여, 패킷이 인터넷으로 포워딩되는 것 같습니다.

개인적으로는 'br-lan' 이라는 이름보다는 IP 주소를 명시적으로 사용하는 것이 직관적이라고 생각됩니다.

저작자 표시
신고
Posted by 훅크선장

OpenWRT를 사용하다보면, USB 디스크 또는 메모리를 usb 포트에 꽂아서 마운트해서 사용하는데,

매번 시스템이 재시작될 때마다, 마운트를 다시 해주어야 하는 불편함이 있다.

왜냐하면, 기존에는 USB 디스크나 메모리의 파티션이 자동으로 디바이스로 인식되어서, 디바이스 명이 /dev/sda1 형태로 되어야만,

# mount /dev/sda1 /mnt

와 같이 명령어로 써야된다.


근데, 디바이스명은 가끔 부팅될때마다 달라질 수 있기 때문에 한계가 있었다.


최근에 OpenWRT 기능을 둘러보면서, 자동 마운트 방법을 알게 되었다.


root@HomeRouter:/etc/config# block info

/dev/mtdblock2: UUID="7f2dadbc-6ae00ebb-ea880768-13b88c63" VERSION="4.0" TYPE="squashfs"

/dev/mtdblock3: TYPE="jffs2"

/dev/sda1: UUID="db459e28-c32b-4f16-8dc1-2edee96031c2" NAME="EXT_JOURNAL" VERSION="1.0" TYPE="ext4"

root@HomeRouter:/etc/config# 


먼저 위와 같이, block info 라는 명령어로 USB  디스크의 UUID를 알아낸다.


그리고,

/etc/config/fstab 에 가서 다음과 같이 추가한다.

# vi /etc/config/fstab

...

중략

...

config mount

              option uuid 'db459e28-c32b-4f16-8dc1-2edee96031c2'

              option enabled '1'

              option target '/mnt'


그러면, UUID를 'db459e28-c32b-4f16-8dc1-2edee96031c2'로 가진 디바이스가 항상 /mnt 디렉토리로 자동 마운트가 된다.



그냥 아주 쉽게, LUCI 웹 인터페이스에서 메뉴 System -> Mount Points 에 들어가면, 설정할 수도 있다.




저작자 표시
신고
Posted by 훅크선장

OpenWRT에서도 Web Proxy를 운용할 수 있다는 것을 최근에 알게되어서...


다음의 링크들을 보고 설정하였음.


http://wiki.openwrt.org/doc/howto/proxy.tinyproxy

https://forum.openwrt.org/viewtopic.php?id=40631



1. 설치하기

# opkg update

# opkg install tinyproxy luci-app-tinyproxy


2. tinyproxy 설정하기

서비스 활성화 먼저 하고, 

# /etc/init.d/tinyproxy enable


설정파일을 다음과 같이,

# vi /etc/config/tinyproxy


config tinyproxy

    option User 'nobody'

    option Group 'nogroup'

    option Port '8888'

    option Timeout '600'

    option DefaultErrorFile '/usr/share/tinyproxy/default.html'

    option StatFile '/usr/share/tinyproxy/stats.html'

    option MaxClients '100'

    option MinSpareServers '5'

    option MaxSpareServers '20'

    option StartServers '10'

    option MaxRequestsPerChild '0'

    option ViaProxyName 'tinyproxy'

    list ConnectPort '443'

    list ConnectPort '563'

    option enabled '1'

    option FilterExtended '1'

    option Filter '/lib/uci/upload/cbid.tinyproxy.cfg02822b.Filter'

    option FilterURLs '1'

    option LogLevel 'Connect'

    option Syslog '1'

    option enable '1'

    option Allow '192.168.1.0/24'


위에서 자신에 맞게 수정할 것은 딱 두개뿐

option Port '8888'    이것이 바로 프록시 접속 포트번호,  보통 프록시 포트는 3128을 많이 쓰지만, 자신이 원하는 포트로 변경해서 사용하기를 권장.

그리고, option Allow '192.168.1.0/24' 가 바로 접속을 허용할 IP 주소 영역을 지정하므로, 자신이 사용하는 IP 대역만을 지정하는 것이 필요.

(그냥 '0.0.0.0/24' 라고 모든 접속을 허용해 놓더라도, iptables 같은 방화벽에서도 충분히 필터링 할 수 있음. 어차피 방화벽을 열어야하기 때문에 많이 고민하지 않아도 됨.)


서비스 실행

# /etc/init.d/tinyproxy start    또는 restart


# lsof -i 명령어로 포트가 열리고, ps elf 로 서비스가 실행되었는지를 확인하기 바람.


3. 방화벽에 리다이렉트 룰과  IP 필터링 룰 설정하기

# vi /etc/config/firewall


위 방화벽 설정 파일에 다음 내용을 추가한다.


config redirect

    option _name 'proxy'

    option src 'lan'

    option proto 'tcp'

    option src_dport '80'

    option dest_port '8888'

    option src_dip '!192.168.1.1'

    option dest_ip '192.168.1.1'


여기서 가장 중요한 설정은 바로 192.168.1.1  IP 주소로, 반드시 현재 OpenWRT에서 사용하는 로컬LAN의 라우터  IP 주소를 써주어야 함!!

8888  포트 번호는 반드시 앞에서 tinyproxy 설정 포트번호와 동일해야 함.


# vi /etc/firewall.user


파일에 접속 허용을 추가한다.


iptables -I INPUT 1 -p tcp -s 220.25.11.1/24 --dport 8888 -j ACCEPT


위와 같이, 특정 IP 대역에서만 포트번호 8888로 접속할 수 있도록 설정한다.

만약 모든 곳에서 들어올 수 있도록 하려면, 그냥

iptables -I INPUT 1 -p tcp --dport 8888 -j ACCEPT

라고, 설정한다.

앞에서 tinyproxy의 option Allow ''를 이용해서, 접속 제한을 할 수 있다. 알아서 잘 선택하면 된다.


추가.

OpenWRT 같은 홈라우터에서 혼자서 사용한다면, 홈라우터 자원을 너무 많이 사용하면서 대기하지 않도록,

/etc/config/tinyproxy 설정 파일에서

Option MaxClients 와  Option StartServers 설정을 조금 낮춰주는 것이 좋다.




저작자 표시
신고
Posted by 훅크선장

콘솔 즉, SSH 터미널 접속을 한 다음에, 다음 명령어로 맥주소를 자유롭게 바꿀 수 있다.

아래는 wan 쪽 주소를 바꾸는 예제이다.

# uci set network.wan.macaddr="<mac_address>"
# uci commit network
# ifdown wan && ifup wan

<mac_address> 의 예제는 01:23:45:67:89:ab 이다.

저작자 표시
신고
Posted by 훅크선장

TP-LINK MR3420 제품에 OpenWRT 펌웨어를 업로드하는데 성공하였습니다.

국내에서는 동일한 하드웨어를 사려면, 거의 두 배 가격을 줘야되는데, 5만원 정도에 이정도 성능의 하드웨어를 구할 수 있다는 데에 참으로 감동~!






신고
Posted by 훅크선장

마이크로소프트웨어 4월호 목차 : 

http://www.imaso.co.kr/?doc=bbs/gnuboard.php&wr_id=39584&bo_table=article

중간에 보면,

Do It Yourself | 임베디드 리눅스 OpenWrt 알아보기│정계옥 168

국내에서 판매중인 유·무선공유기에 OpenWRT를 설치하고, VPN 서버등을 구축하는 글입니다.


실력도 미천하고, 글재주도 없지만, 그래도 한번 용기내서 써봤습니다.

비판은 잠시 접어두시고, 격려의 말만 받습니다.  * ^ ^ *


-----------------------------------------------------------------

그런데, 4월 원고를 보내면서 “각주”를 넣었는데, 다 빠졌네요~.

원고 중에 다른 분들이나 다른  사이트에서 참고한 사항이 다 빠졌습니다.

4월 내용에서 국내의 OpenWRT 사이트 OpenWRT KR, http://openwrt.ssu.ac.kr/ 에서 자료를 많이 참고한 것에 대한 각주 내용이 누락된 것에 관련자 분들께 사과드립니다. 

5월 원고에는 참고한 사이트들을 추가하였습니다.

신고
Posted by 훅크선장

티스토리 툴바